Strop de Aer S.R.L. · support@bloxly.dev · bloxly.dev
AI Chat is fully operational again. The issue was caused by a routine infrastructure configuration update on our end that temporarily interrupted connectivity to the AI provider. The fix has been applied and all services are running normally.
Resolved
AI Chat is fully operational again. The issue was caused by a routine infrastructure configuration update on our end that temporarily interrupted connectivity to the AI provider. The fix has been applied and all services are running normally.
Investigating
The earlier fix resolved the 500 errors on stream startup, but we are now seeing elevated error rates from the LLM provider.
Monitoring
Fix is deployed. Added Flush() to the metrics response writer wrapper.
Monitoring logs and error rates for the next 10 minutes to confirm stability.
Identified
Root cause found. The metrics middleware wraps http.ResponseWriter in a custom struct to track Prometheus metrics. That struct was missing a Flush() method.
We are actively developing a fix to this issue.
Investigating
Users are unable to send messages in AI Chat. All requests to POST /api/chat/stream are returning HTTP 500.